summary refs log tree commit diff
path: root/lib/systems/examples.nix
diff options
context:
space:
mode:
authorCrystalGamma <github@crystalgamma.de>2018-08-21 21:31:34 +0200
committerJohn Ericson <mail@JohnEricson.me>2018-08-21 15:31:34 -0400
commit72d161f548701a2a8dab334dee76b63bccc0f07c (patch)
treeb7e2e8d922684bd5b7c3d269454a0a8145a44e46 /lib/systems/examples.nix
parentcb44c3ff4cf2c15c7e870df482126bd09ce46588 (diff)
downloadnixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.gz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.bz2
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.lz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.xz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.zst
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.zip
[RFC] ppc64le enablement (#45340)
* ppc64le enablement

* gcc, glibc: properly handle __float128

* lib/systems, stdenv: syntax cleanup

* gcc7: remove ugly hack

* gcc: add/update __float128 flags

* stdenv: add another pair of quotes for consistency

* gcc: move __float128 flag for ppc64le-glibc into common/platform-flags.nix
Diffstat (limited to 'lib/systems/examples.nix')
-rw-r--r--lib/systems/examples.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/systems/examples.nix b/lib/systems/examples.nix
index 31772ba0054d..3828b2f84c64 100644
--- a/lib/systems/examples.nix
+++ b/lib/systems/examples.nix
@@ -8,6 +8,14 @@ rec {
   #
   # Linux
   #
+  powernv = {
+    config = "powerpc64le-unknown-linux-gnu";
+    platform = platforms.powernv;
+  };
+  musl-power = {
+    config = "powerpc64le-unknown-linux-musl";
+    platform = platforms.powernv;
+  };
 
   sheevaplug = rec {
     config = "armv5tel-unknown-linux-gnueabi";