summary refs log tree commit diff
path: root/lib/generators.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2016-11-17 22:29:32 +0100
committerProfpatsch <mail@profpatsch.de>2016-11-17 23:19:28 +0100
commit53fc7b8272cf762c57dd3e113863aa99feb35e5d (patch)
tree97288f00a2369c7ed303ee87db27d0e1ce655090 /lib/generators.nix
parent26eb10e771c2e7abdfe79d7f3db472af2e56a9fd (diff)
downloadnixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar.gz
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar.bz2
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar.lz
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar.xz
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.tar.zst
nixlib-53fc7b8272cf762c57dd3e113863aa99feb35e5d.zip
lib/generators: add manual documentation
Restructures the functions reference a bit.
Diffstat (limited to 'lib/generators.nix')
-rw-r--r--lib/generators.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/generators.nix b/lib/generators.nix
index a13968736957..27d4142e8d9a 100644
--- a/lib/generators.nix
+++ b/lib/generators.nix
@@ -1,6 +1,11 @@
-/* Functions that generate widespread config file
+/* Functions that generate widespread file
  * formats from nix data structures.
+ *
+ * They all follow a similar interface:
+ * generator { config-attrs } data
+ *
  * Tests can be found in ./tests.nix
+ * Documentation in the manual, #sec-generators
  */
 with import ./trivial.nix;
 let