summary refs log tree commit diff
path: root/lib/deprecated.nix
diff options
context:
space:
mode:
authorTom Saeger <tom.saeger@gmail.com>2017-04-19 14:41:28 -0500
committerTom Saeger <tom.saeger@gmail.com>2017-04-19 19:37:55 -0500
commit5989515b9410f3d557e1aba037325a218f4338f5 (patch)
treec3edb273a11bf7625c56b1915b0ba0283ab5b133 /lib/deprecated.nix
parente662e035f9ed4d125c7534bc65e01fc73a0b0f62 (diff)
downloadnixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar.gz
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar.bz2
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar.lz
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar.xz
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.tar.zst
nixlib-5989515b9410f3d557e1aba037325a218f4338f5.zip
lib: trivial spelling fixes
Diffstat (limited to 'lib/deprecated.nix')
-rw-r--r--lib/deprecated.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/deprecated.nix b/lib/deprecated.nix
index 45a3893fc22d..983e8d26892b 100644
--- a/lib/deprecated.nix
+++ b/lib/deprecated.nix
@@ -253,11 +253,11 @@ rec {
   # eg { a = 7; } {  a = [ 2 3 ]; } becomes { a = [ 7 2 3 ]; }
   mergeAttrsConcatenateValues = mergeAttrsWithFunc ( a: b: (toList a) ++ (toList b) );
 
-  # merges attributes using //, if a name exisits in both attributes
+  # merges attributes using //, if a name exists in both attributes
   # an error will be triggered unless its listed in mergeLists
   # so you can mergeAttrsNoOverride { buildInputs = [a]; } { buildInputs = [a]; } {} to get
   # { buildInputs = [a b]; }
-  # merging buildPhase does'nt really make sense. The cases will be rare where appending /prefixing will fit your needs?
+  # merging buildPhase doesn't really make sense. The cases will be rare where appending /prefixing will fit your needs?
   # in these cases the first buildPhase will override the second one
   # ! deprecated, use mergeAttrByFunc instead
   mergeAttrsNoOverride = { mergeLists ? ["buildInputs" "propagatedBuildInputs"],