summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2017-09-28 18:51:20 -0400
committerShea Levy <shea@shealevy.com>2017-09-28 18:51:20 -0400
commit01a3f0b8aabdb321b15dc7cc0e2287ce8232f797 (patch)
tree37562d65b0fc2fdc0f81da3ac22cb8637ea61ad8 /lib/default.nix
parent9ce7175cfe9edf5f7eb9a9f299807047a4feeaf1 (diff)
downloadnixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar.gz
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar.bz2
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar.lz
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar.xz
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.tar.zst
nixlib-01a3f0b8aabdb321b15dc7cc0e2287ce8232f797.zip
Avoid polluting lib namespace unncessarily
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 9da78ff0da7c..3e30ec515fcb 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -60,7 +60,7 @@ let
       nixpkgsVersion mod;
 
     inherit (fixedPoints) fix fix' extends composeExtensions
-      makeExtensible makeExtensibleWithCustomName makeExtensibleWithInterface;
+      makeExtensible makeExtensibleWithCustomName;
     inherit (attrsets) attrByPath hasAttrByPath setAttrByPath
       getAttrFromPath attrVals attrValues catAttrs filterAttrs
       filterAttrsRecursive foldAttrs collect nameValuePair mapAttrs
@@ -88,8 +88,7 @@ let
     inherit (stringsWithDeps) textClosureList textClosureMap
       noDepEntry fullDepEntry packEntry stringAfter;
     inherit (customisation) overrideDerivation makeOverridable
-      callPackageWith callPackagesWith addPassthru hydraJob makeScope
-      callPackageWithOutputWith;
+      callPackageWith callPackagesWith addPassthru hydraJob makeScope;
     inherit (meta) addMetaAttrs dontDistribute setName updateName
       appendToName mapDerivationAttrset lowPrio lowPrioSet hiPrio
       hiPrioSet;