summary refs log tree commit diff
path: root/lib/build-vms.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-09-02 08:36:30 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-09-02 08:36:30 +0000
commit137c5c65bd3f10f7ccb41e2b0cda52f467944780 (patch)
treef5dcc87bc4e29b7885fbf67b77c95a63a97bbb87 /lib/build-vms.nix
parentb1aa227cbdca8c7c17e622c8cdf89949e06e66f4 (diff)
downloadnixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar.gz
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar.bz2
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar.lz
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar.xz
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.tar.zst
nixlib-137c5c65bd3f10f7ccb41e2b0cda52f467944780.zip
* Added a timeout for starting the VM. TODO: handle SIGCHLD from
  qemu.
* Do the subversion test on i686-linux.  

svn path=/nixos/trunk/; revision=16923
Diffstat (limited to 'lib/build-vms.nix')
-rw-r--r--lib/build-vms.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/build-vms.nix b/lib/build-vms.nix
index 939c1ecc51c2..39ae9b77cf37 100644
--- a/lib/build-vms.nix
+++ b/lib/build-vms.nix
@@ -1,6 +1,7 @@
 { nixos ? ./..
 , nixpkgs ? /etc/nixos/nixpkgs
 , services ? /etc/nixos/services
+, system ? builtins.currentSystem
 }:
 
 let pkgs = import nixpkgs { config = {}; }; in
@@ -55,7 +56,7 @@ rec {
     nodes: configuration:
 
     import "${nixos}/lib/eval-config.nix" {
-      inherit nixpkgs services;
+      inherit nixpkgs services system;
       modules = [ configuration ];
       extraArgs = { inherit nodes; };
       /* !!! bug in the module/option handling: this ignores the