summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-12-15 23:54:10 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-12-15 23:54:10 +0000
commitc155a3f46e44a08b1a2cca0ab5e3da9c39c685a1 (patch)
treea09a1d438268e18859b84f2d9b90017a262756ed /default.nix
parent8373c890a8aa80b1626cf84b7fb812839b70b477 (diff)
downloadnixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar.gz
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar.bz2
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar.lz
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar.xz
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.tar.zst
nixlib-c155a3f46e44a08b1a2cca0ab5e3da9c39c685a1.zip
* When doing chroot builds, the `build-chroot-dirs' option should
  include the closure of /bin/sh.  Otherwise all builders that call
  /bin/sh will fail when using the new chroot implementation, which
  only bind-mounts the inputs of a build rather than the whole Nix
  store.

svn path=/nixos/trunk/; revision=13640
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 3923cb9592b7..46f2d265216f 100644
--- a/default.nix
+++ b/default.nix
@@ -1,6 +1,6 @@
 let
 
-  fromEnv = name : default :
+  fromEnv = name: default:
     let env = builtins.getEnv name; in
     if env == "" then default else env;
   configuration = import (fromEnv "NIXOS_CONFIG" /etc/nixos/configuration.nix);